Logic Pro 7
TDM Guide
Contents

Preface  5  An Introduction to TDM Systems
      5  About This Guide

Chapter 1  7  Audio Hardware and Drivers
      7  Hardware Setup
      8  Drivers
     14  Digidesign Hardware Setup
     14  Adaptation of Songs Produced With Other Hardware

Chapter 2  15  About TDM
      15  Differences to Native Processing
      16  TDM Plug-ins
      17  Specific Characteristics
      19  Simultaneous Operation of TDM and Other Hardware

Chapter 3  21  ESB TDM and EXS24 TDM
      21  Features
      22  EXS24 TDM
      24  ESB TDM

Chapter 4  29  Audio Export and Import
      29  OMF Export
      30  OMF Import
      30  AAF Export
      30  AAF Import

Chapter 5  31  Tips and Tricks
      32  ESB TDM Differences Mac OS 9 and Mac OS X
      33  How to Import Songs from Mac OS 9 Systems
      34  How to Import Native Songs from Any System
      34  Using DAE, DTDM, and Core Audio Simultaneously
      34  System Performance and TDM DSP Usage
      35  Bounce Strategies
An Introduction to TDM Systems

In general, DAWs take one of two approaches for the task of audio signal processing: the use of dedicated hardware DSPs (TDM systems), or the native processing capabilities of the computer’s CPU.

Logic Pro allows you to make use of your TDM system DSPs in conjunction with your computer’s native CPU processing resources.

The link between the DSP world of your TDM system, and your computer’s native CPU processing resources is the ESB TDM (Emagic System Bridge TDM).

The ESB TDM allows your computer’s CPU to processes one audio engine (Direct TDM), and the DSP of the TDM hardware to processes another (DAE). This is done by using two different mixers in Logic’s Environment: A TDM Mixer (using the DAE) and a native mixer (called the DTDM Mixer). The first one handles TDM plug-ins, while the other works with native plug-ins in both Audio Unit and Logic formats.

Up to eight of the DTDM Mixer outputs can be routed into the TDM Mixer. The output signals are received by the virtual ESB TDM inputs—chosen as Inputs on the TDM Aux Objects. This enables all Logic tracks, native and Audio Unit plug-ins—including software instruments—to be used in conjunction with your TDM system DSPs.

The output of the TDM mixers is fed via connected Digidesign TDM hardware.

About This Guide

This guide will introduce you to all that you “need to know” to get your TDM hardware up and running with Logic Pro.

We will also introduce you to the ESB TDM and EXS24 TDM. These expand and enhance the flexibility of your Logic and DAE/TDM production system.

Further to this, you will also learn about importing and exporting audio between the Logic and Pro Tools software.
We have presumed a level of knowledge on the general concepts of DAWs (Digital Audio Workstations) and basic computer operations.

We have also assumed that you have connected your TDM system to your Macintosh, and have installed (and tested) the Pro Tools system software. A correctly installed and operational ProTools system will ensure a reliable Logic Pro/DAE system.

**Note:** Please carefully read and follow the instructions of your Digidesign ProTools installation manual.

The connection of your MIDI interface hardware and any external MIDI synthesizers or modules is also presumed to be working correctly.

The use of Logic Pro's functions is discussed in the accompanying Reference and Onscreen Help system—accessible from the Logic Pro Help menu.

**Conventions of this Guide**

Before commencing, we'd like to cover the following conventions used in this manual.

**Menu Functions**

For functions that can be reached via hierarchical menus, the different menu levels are described as follows: `Menu > Menu entry > Function`.

**Important Entries**

Some text will be shown as follows:

**Important:** Information on function or parameter.

These entries discuss a key concept or technical information that should, or must, be followed or taken into account. Please pay special attention to these entries.

**Notes**

Some sections provide additional information or tips that will assist your use of Logic. These are displayed as shown below:

**Note:** Information on function or parameter.

**Key Commands**

Many Logic functions can be activated or accessed with key commands—computer keyboard or MIDI controller shortcuts. The key commands mentioned in this guide are based on the Default Key Command set, assigned by the Logic Setup Assistant.
This chapter provides you with the information required to set up Logic with TDM hardware.

In the initial section, you will be introduced to TDM hardware that can be used with Logic Pro and drivers for this hardware. You will then learn all about appropriate driver settings. The latter portion discusses the adaptation of songs that were produced with different hardware.

Hardware Setup
Trouble-free operation of Logic requires the correct installation and configuration of the audio hardware and drivers. Please refer to the documentation that shipped with your Digidesign audio hardware to configure your computer and hardware for optimal performance.

Logic Pro supports all audio hardware that offers a Core Audio driver, and Digidesign TDM hardware that works with DAE under Mac OS X.

You can also use your TDM audio interfaces by making use of Core Audio. This may be beneficial in certain cases, should you wish to open songs created in native audio engines.

We will primarily concentrate on the setup of supported Digidesign TDM hardware in this guide, but will also cover appropriate Core Audio hardware settings. This information may prove useful as you may wish to combine both the native and TDM engines of Logic, and make use of a Core Audio device in conjunction with your TDM hardware.

The simultaneous use of multiple audio cards is useful for increasing the number of inputs and outputs, for example. Dependent on computing power and the connected audio hardware, this can raise the number of stereo audio tracks to over 255!
Drivers
All audio hardware requires a driver, which acts as a communication link with the Logic software. To use particular hardware, its/their drivers need to be activated.

Selecting and activating a particular audio hardware device is achieved directly in Logic, via the Audio > Audio Hardware and Drivers dialogs. Logic will automatically recognize any installed Core Audio hardware, and will use the default settings—as defined in the Audio MIDI Setup pane—for it. It can, however, be advantageous to optimize the settings for your individual hardware setup, particularly if you use more than one audio driver or a multi I/O card.

In such cases, you should fine tune the audio hardware settings.

You can choose between the Core Audio, DAE, and Direct TDM panes in Logic’s Drivers preferences.

Core Audio
The Core Audio pane refers to the internal audio inputs and outputs of your Mac, or another audio hardware device that uses Core Audio drivers. The Core Audio driver parameters are described in “Core Audio and Direct TDM Settings” on page 9.

DAE
DAE is the abbreviated form of Digidesign Audio Engine. This is the driver software for many Digidesign cards, and is primarily used for the operation of TDM hardware and/or access to their on-board DSP chips.

The following Digidesign hardware is currently supported by Logic Pro via the DAE:
• ProTools HD Accel/HD/MIX/24/MIX

The following Digidesign hardware is unsupported by Logic Pro via the DAE:
• AudioMedia III, Digi001, M Box, Digi002, and 002R

You can operate these interfaces as plain audio I/O cards, through use of a Core Audio driver.

You will find more information on the DAE parameters in the “DAE Settings” on page 12.

Direct TDM
To use Direct TDM (DTDM), you require any of the abovementioned TDM hardware from Digidesign, and the ESB TDM.

ESB TDM—included in Logic Pro—connects the DTDM native audio engine with the DAE.
This allows your computer’s CPU to perform processes in Logic’s native DTDM Mixer, including: audio track playback, the use of software-based instruments such as those incorporated into Logic plus Audio Units instrument and effect plug-ins.

Up to eight audio streams emanating from this native mixing board can be fed into your TDM mixer, where the data can be further processed with TDM plug-ins.

The Direct TDM driver parameters are described in the “Core Audio and Direct TDM Settings” section below. Read more about the “ESB TDM” on page 24.

Note: If you hold down the Control key when you start Logic, a dialog box appears, allowing you to switch off individual drivers or all audio drivers, for this particular launch of the program. You can start Logic more quickly without audio drivers, should you only want to use it as a MIDI sequencer.

Note: It’s a good idea to frequently visit the Digidesign web pages (and those of your audio hardware manufacturer, if using an additional Core Audio device) in order to obtain the latest drivers. The manufacturer’s website is often a good source for information on available drivers, compatibility issues and troubleshooting tips.

Core Audio and Direct TDM Settings
Core Audio and Direct TDM have many of the following parameters in common:

I/O Buffer Size
This parameter determines the size of the buffer used by the audio hardware—for both input and output. Options range from 32 up to 1024 samples. The smaller the buffer size, the less “latency” you will encounter when monitoring while recording, or using software instruments.

Note: There may be a point where the selected I/O Buffer Size is too small for your system, and begins to affect playback. This usually takes the form of clicks, pops, and crackles. You should therefore aim for the lowest possible I/O Buffer Size value that doesn’t introduce these types of artefacts.

As this parameter value is reduced, it places a higher strain on the CPU(s) of the system. On current Macintosh models, you should be able to reduce this value down to its minimum. As a word of advice, if you find a higher (larger) I/O Buffer Size setting provides suitably low latency during record monitoring and software instrument playback, you should use it. This will minimize the impact on the CPU(s) of your system. You may wish to use a lower setting while recording (lower latency) and increase the I/O Buffer Size for better overall stability while editing or mixing (bounce).
Recording Delay
This parameter is measured in samples. It allows the recording of Audio Regions to be delayed by a certain fixed value. It helps advanced users to compensate for the delay that may be caused by incorrect delay information being provided by the driver. Normally you don’t have to bother with this parameter.

Max. Number of Audio Tracks
The Audio Engine requires free system memory, which is not assigned to Logic or any other application. The amount of memory required depends on:
• the maximum number of tracks to be played
• the number of I/O channels supplied by the driver

This setting allows you to reduce the amount of memory required by the driver through a reduction in the number of tracks. This may be useful when you want to run other applications or drivers simultaneously. Range is from 4 to 255 tracks.

As you change the Max. Number of Audio Tracks value by dragging the slider left or right, the System Memory Requirement value will update in realtime.

64 Busses
This checkbox allows the use of up to 64 Bus Objects. Logic Pro normally restricts the number of Bus Objects to 32. If you need to create more, check this box, and add the desired Objects.

Universal Track Mode
Universal Track Mode, when engaged, allows the playback of stereo and mono Regions on a single track. Even-numbered Audio Objects are not regarded as the right channels of the odd-numbered stereo Audio Objects to their left, and every Audio Object has its own Mono/Stereo button. Dependent on whether a mono or stereo Region is played back, the Pan knob will behave as Balance or Pan control. If you play back a mono Region, and the Pan knob is set to the center position, both channels of the Audio Object will output the same signal level.

Note: Universal Track Mode has limited routing capabilities, as it is not possible to handle the left and right audio channels separately.

The Non-Universal Track Mode is useful if you wish to play different mono files for the left and right mono channels of a single Audio Object, even when it is assigned as a stereo track. A stereo/stereo plug-in inserted on this stereo track receives different signals for the left and right channels.
**Important:** In order to change tracks to or from DAE/TDM, always switch Universal Track Mode off, and work with split stereo or mono files. Also be aware that DAE/TDM does not currently work with interleaved stereo files. If your tracks need to be switched between DAE/TDM and other systems, split stereo files should be used. To do so, enable the Preferences > Audio > General > Force record & convert interleaved into split stereo file(s) parameter.

Please reboot Logic after changing the Universal Track Mode setting.

**Larger Disk Buffer**

This option influences the amount of audio data that is read from the disk in advance. It is switched off by default, matching the demands of fast hard drives and powerful computers. If you encounter frequent error messages while running Logic, you should switch this setting on. This will allow you to play back more tracks, achieving higher reliability. Please note that RAM requirements are increased if this option is active.

**24 Bit Recording**

When this setting is active, Logic can record 24 bit files. Please keep in mind that this only makes sense if you are actually using a 24 bit interface. As long as your audio hardware is capable of this bit depth, you can select this option in the Audio > Audio Hardware & Drivers window.

24 bit recordings offer a significant improvement in the available dynamic range, but require high quality peripheral components such as; microphones, preamplifiers, and high quality AD/DA converters. 24 bit files use one and a half times more disk space than comparable 16 bit files.

**Note:** More information about the use of bit depths, can be found in the following section.

**Software Monitoring**

This option allows you to switch Software Monitoring (listening to the actual input signal) on or off. Please note that with Software Monitoring active, the audio signal is processed via Logic—so a certain amount of audible delay (commonly referred to as latency) is inevitable—although this may be so small that it can't be heard. If you are listening to the recording signal through your mixing desk, or your audio hardware supports hardware monitoring, you should switch this option off.

The decision to switch Software Monitoring on, or to listen to the incoming signal as output by your (analog) mixing desk, depends on the latency time that can be achieved with the system.
DAE Settings
The DAE parameters can only be set after activating the DAE. To do so, check the Enabled box in the upper left corner of the DAE pane. You will then have access to the following parameters:

Global Bit Depth
This parameter allows you to choose between 16 bit or 24 bit playback and recording.

Note: The DAE does not allow the use of 16 and 24 bit files simultaneously.

About Sample Rates and Bit Depths
Some audio hardware, such as Pro Tools HD, supports high sampling rates of 88.2, 96, 176.4, or 192 kHz. Logic Pro supports these high sample rates. The sample rates can be selected in the Audio > Sample Rate menu. Note that these higher sample rates require two or four times the hard disk space, and that the audio engine will be required to perform two or four times as fast as a 44.1 kHz rate. You should consider that the improvement in audio quality of 96 kHz recordings, compared with 44.1 kHz, is fairly minor. More significant differences can be heard between 16 and 24 bit recordings. Many audio engineers consider 44.1 kHz, 24 bit recording to be the best balance between sound quality, and efficient use of resources. For modern DVD production higher sample rates may be required.

Logic allows the simultaneous playback of audio files of different bit depths (16 and 24) within the same song, using a native audio engine.

If you want to use both bit depths natively, please ensure that the DAE engine is set to 24 bit.

PT HD Type
This parameter allows you to define the number of tracks for your PT HD or HD Accel system. Each entry in the pop-up menu allows you to define the required number of tracks, based on the number of PT HD DSPs that you wish to use (and actually have) in your system.

MIX Card Type
This pop-up menu option determines the number of tracks that are possible from your MIX Card system. Options are 32 Tracks or 64 Tracks. Setting it to 32 Tracks will save resources and is highly recommended, when using DTDM in parallel with MIX hardware.

TDM Setup Indicator
The TDM Setup Indicator is a small status window that shows the current TDM process, such as when inserting a TDM plug-in, for example. This parameter enables you to switch the display of this window on or off.
Release in Background if Stopped
We strongly recommend that you do not enable this option until the DAE and standalone Digidesign Core Audio driver support this feature.

Activation of this parameter will release the TDM hardware when Logic is not in play or record mode, allowing you to address the hardware with another application—such as the Pro Tools software or a sample editing program.

Common Parameters
At the bottom of each Drivers pane you can see four pop-up menus, which provide you with the following settings.

Process Buffer Range
This parameter determines the size of the native buffer that is used to compute mixers and effects. You can choose between Small, Medium, and Large buffer sizes.

*Note:* Larger buffer sizes will increase latency. Dependent on CPU speed, buffer sizes that are too small may compromise realtime audio processing.

*Note:* This setting is not valid for the DAE.

Rewire Behavior
When sending MIDI data to a Rewire compatible software instrument, you can choose between:

- **Playback mode:** use when playing back MIDI tracks via Rewire. This setting requires less CPU power.
- **Live mode:** use when playing a Rewire instrument live. This setting requires more CPU power.

*Note:* Please note, that this setting is not valid for the DAE.

Maximum Scrub Speed
Sets the maximum scrub speed. *Normal* means the playback speed is used, *Double* playback speed is twice as fast.

Scrub Response
Determines the reaction time for audio scrubbing. Choose the value that works best for your system configuration. Options are: Slow, Normal, Fast, Faster.
Digidesign Hardware Setup
The Digidesign Hardware Setup dialog box contains all important System settings for your Digidesign hardware. This is where you determine whether Logic will use the analog or digital inputs, when recording. You can also check your hardware, to ensure that it is functioning properly. If you own several Digidesign hardware units, you can select from among them here.

You can open the Digidesign Hardware Setup window via the Options > Digidesign Hardware Setup menu item, within the Audio window.

Adaptation of Songs Produced With Other Hardware
If using a TDM system, you may often encounter situations where you need to load songs that were produced with other hardware. Logic makes handling such situations very simple: When you load a song (of any origin), Logic checks whether its Audio Object drivers are activated or not. If they are not—which may be the case when a song was produced on another computer with different hardware—the driver settings will be “switched” to a compatible (Core Audio or DTDM) driver for the hardware that is installed in your computer.

As the final step in “adapting” the song, Logic checks whether or not there is an Audio Object available for every channel of your hardware. If there isn’t, a suitable number of Objects will be created automatically. This facility means that whenever you change the hardware in a given computer, or if you take song data to another computer with different hardware, the Audio Objects will change as well—while maintaining their EQ, effect, and send settings.

Should the plug-ins used by the song be different on the two computers, the plug-ins that are not available will be grayed out in the Insert slots of the appropriate channels. You will need to manually insert/replace these plug-ins with plug-ins that are available for use on the target computer.

**Note:** In order to be compatible with Digidesign DAE/TDM systems, all stereo recording should take place in split stereo. For DAE/TDM compatibility, activate Preferences > Audio > Force record & convert interleaved into split stereo file(s).
About TDM

Logic Pro allows you to make use of the TDM functions supported by ProTools HD Accel, HD, Mix, and 24/MIX systems.

TDM stands for Time Division Multiplexing, the time-interlaced transmission of several digital audio signals through a single data bus. This bus system is physically isolated from the computer system bus, and runs between the individual TDM-capable PCI boards. 256 (MIX) or 512 (with HD/HD Accel) digital audio channels, each with 24 bit resolution, can be transmitted on the TDM bus. These signals form the signal paths within a virtual mixer. These signal paths are necessary for the insertion of plug-ins, which are calculated on the DSP card (DSP = Digital Signal Processor), and routed into the individual channels, or are selected through auxiliary busses.

**Note:** You should only use hard drives mentioned on the compatibility list provided by Digidesign, for recording.

Pro Tools HD systems increase the sample rates possible, the number of tracks and the number of channels on the TDM II bus.

**Note:** It should be noted that the TDM channel count is sample rate dependent, so if a rate of 88.2 or 96 kHz is used, the 512 channels available to a PT HD system will be halved to 256. At a sample rate of 192 kHz, this will again be halved to 128.

**Differences to Native Processing**

Basically, the use of Logic with a TDM system is very similar to the use of Logic with the native processing capabilities of your computer. Here is an overview of the main differences between the two systems:

- In a TDM system, all audio processing is done by the DSP chips incorporated into the TDM hardware. This means that the native Logic plug-ins cannot be run on the TDM DSPs. TDM plug-ins, however, can be fully used and automated.
• The TDM hardware determines the overall features of the system: number of tracks, number of TDM plug-ins that can be used simultaneously, number of in/outputs and so on. Please refer to the manuals delivered with your ProTools system for further information.

• Stereo recordings require two tracks, and are recorded as two separate files. In the Arrange window a stereo recording is handled as two linked Regions, which use two tracks. In the Sample Editor stereo recordings are displayed as stereo file. All odd-numbered Track Objects can be switched to stereo. Doing so will cause the following even-numbered tracks to be “locked” to the preceding odd-numbered tracks. The odd numbered track controls both sides of the stereo recording.

**TDM Plug-ins**

TDM compatible plug-ins can be used in Logic. Please make sure that the plug-ins are installed correctly. The use of TDM plug-ins is very similar to the use of native plug-ins. TDM plug-ins can be fully automated.

**Note:** Logic does not support TDM Surround and multi mono plug-ins with two or more channels.

**Plug-in Settings**

All TDM plug-in settings are saved with the song, and are automatically restored the next time the song is loaded.

You can also use plug-in settings to manage the parameters of a plug-in. This method is comparable to the storage locations of an external effects device, combined with a clipboard for effects parameters.

In the gray header at the top of the Plug-in window, you can open the Settings pull-down menu by clicking on the arrow button. It offers the following options:

**Copy Setting**

Copies all parameters into an independent plug-in Clipboard. These parameter settings remain here, until Copy Setting is next selected. This does not affect the global Logic Clipboard.

**Paste Setting**

If you have opened a plug-in of the same type, you can paste the parameter set from the plug-in Clipboard. This allows you to quickly set up several plug-ins of the same type, or exchange settings between songs.

**Save Setting**

This allows you to save all of the current plug-in parameters to disk. This is useful if you have created a special sound effect that you want to use in future.
Load Setting
Loads stored parameter settings from disk. The file selector box only shows settings for compatible plug-in types. It can also read the Digidesign format for TDM plug-in settings.

The parameter settings of a plug-in can also be copied between the plug-in's mono and stereo versions, and the Digidesign format for plug-in settings can be read (the supplied settings of most plug-ins are saved in this format). Logic automatically displays the corresponding files in the file selection box when loading settings via the Settings menu of Plug-in windows. Settings files are usually located in a Settings folder within the OS X Library/Application Support/Digidesign folder. The name of the most recently chosen setting is indicated by a dot in the menu listing.

Support of TDM Plug-in Side Chains
In applicable TDM plug-ins—Compressors, Noise Gates, Vocoders, and so on—you can select a different source for the side chain input (or key input). You can choose a side chain input source from all tracks, busses or inputs.

RTAS Plug-ins
Please note that RTAS plug-ins are not supported by Logic Pro. Logic Pro only supports Audio Unit, TDM, HTDM, and the native Logic plug-ins supplied with the software.

If you currently own any RTAS plug-ins, you should install the HTDM or Audio Unit equivalents for use in Logic. Most plug-ins are available in several formats.

If no Audio Unit version is available on your RTAS plug-in installation CD(s), please visit the website(s) of the plug-in manufacturer(s).

Specific Characteristics
Please note the following if you want to make use of your hardware's TDM functions with Logic Pro:

Deleting Objects
If you delete an Audio Object in the Environment, by selecting it and pressing Backspace, the level of this Object will be set to zero (minus infinite dB). Output or Bus Objects, however, are an exception: When deleting these, the level will be set to 90 (0 dB); if they weren't, the tracks routed to this Output would not be audible. The other settings (send paths, plug-ins, and sound control) are not deleted, but are merely muted. This way, Logic automatically ensures that DSP processor capacity isn't wasted. As soon as the Object is re-displayed in the Environment, the most recently used level will be restored. In the TDM system, the send and plug-in will be restored.
TDM Mixer Plug-in
Please ensure that there is only one Mixer plug-in within the Plug-ins folder (found inside the DAE folder), which will be either the Stereo Mixer or Stereo Dithered Mixer.

You may also have one of the Surround Mixer plug-ins residing here, but these Mixer plug-ins have no function within Logic Pro.

The Stereo Dithered Mixer requires more DSP capacity than the Stereo Mixer. This may result in a DAE error message (“DSPs maxed out”), when opening older songs with maximum DSP load. In such cases, you should use the Stereo Mixer plug-in.

Changing Global Bit Depth
If TDM hardware is being used, Logic will ask whether you want to use 16 bit or 24 bit bit depth, when launched. You may change the Global Bit Depth in the Audio > Audio Hardware & Drivers dialog box from 16 bit to 24 bit, and vice versa, at a later time.

Note: In many cases, a resolution of 16 bit will be adequate for the individual tracks of a regular multi-track production. This setting requires less space on the storage medium, and a lower data throughput capacity for the hard disk, when playing back the same number of tracks. The 24 bit format is of most benefit on highly dynamic material (classical music productions, for example).

Converting the Bit Depth
If a song containing audio files of different bit depths is loaded, Logic will display a warning message. You can change the bit depth (see above), or you may convert the audio files. Please note that the conversion of 16 bit recordings to 24 bit recordings does not provide any improvement in sound quality, whereas a conversion from 24 bit to 16 bit results in the irrevocable loss of the additional dynamic range possible with 24 bit files.

To convert the bit depth of audio files:
1. In the Audio window, select all of the files to be converted. It may be useful to sort the audio files by bit depth before making your selection. Once done, choose all files to be used in the arrangement with the Edit > Select Used function.
2. Select Audio File > Copy File(s).
3. In the ensuing dialog box, you have the option to set the bit depth. After confirming the dialog, the audio files will be copied—at the selected bit depth.
4. Logic will ask if the references in the current song should be changed to reflect the copied files, rather than the original files.
5. If you want to work immediately with the current song, you should confirm this dialog. Save the song with a different name by selecting File > Save As, if you want to retain the references to the original files in the original song.
Note: You can choose to bounce, rather than copy and convert your audio files from 24 to 16 bit. The advantage of this approach is that the POW-r dithering algorithms can be used to improve the quality of the downsampled audio data.

Sample Editor
All functions of the Sample Editor can be used on 24 bit audio files. You can even exchange sound material in either direction (between 16 and 24 bit files) when using DTDM, via the Copy and Paste commands.

Note: Premiere plug-ins are not supported in Mac OS X. AudioSuite plug-ins are supported at 16 and 24 Bit depth, if using DAE.

Simultaneous Operation of TDM and Other Hardware
Please note the following if you wish to use a TDM system and other audio hardware simultaneously:

Generate Audio Mixer
The easiest way to generate the desired Audio Mixers, would be to run the Logic Setup Assistant again. This is done by choosing Logic > Preferences > Start Logic Setup Assistant.

If you have set up your TDM hardware correctly, you can also generate a TDM Mixer in the Environment automatically.

To do so, follow these steps:

- Open a completely new song with standard defaults (a default song) by pressing Option-Command-N (you can also choose the File > New menu option while holding Option).

Dependent on the connected hardware, this song will include Audio Objects that correspond to the currently active audio hardware, in the Audio layer of the Environment.

Note: If DAE and DTDM, or DAE and Core Audio are activated, only TDM Audio Objects will be generated.

Control Playback
To control playback in the Audio window or in the Sample Editor, select the desired hardware unit and channel, via Channel and Device (at the left side of the window).
Total Number of Audio Tracks
When operating different audio hardware devices simultaneously, the number of possible playback tracks cannot be determined by merely adding them up. This is especially true if the connected systems place a strain on the CPU.

The number of tracks may also be reduced if the connected systems access the same hard disk bus. The impact of this may be significantly lessened (resulting in an increase in the total track number) by using different hard drives for the various systems. As an example; DTDM or Core Audio and/or a QuickTime movie reads from an internal drive, and DAE from an external FireWire or SCSI drive.

Please carefully read and follow the instructions outlined in the Digidesign compatibility guidelines.
With the ESB TDM and EXS24 TDM Logics provides you with two plug-ins that enhance your TDM system.

The ESB TDM and EXS24 TDM expand your TDM mixer—controlled by Logic Pro. If working at 44.1/48 kHz, up to 32 additional channels are available. These extra channels can be used for multiple EXS24 sampler instances and/or up to eight inputs routed from DTDM, the native audio engine running in parallel to the DAE.

**Features**
The ESB TDM plug-in allows the routing of up to eight audio channels of the native (computer CPU processing) DTDM mixer into the DSP-based TDM mixer.

This, in essence, is similar to having a card equipped with a multi channel digital output installed in the computer, and physically connected to an additional multi channel input module for your TDM system. The ESB TDM effectively replaces the audio card’s digital outputs and driver, the TDM audio interface and the cables between them.

ESB TDM routes digital signals via software within the computer, with no need for any additional hardware to be installed or cabled.

The EXS24 TDM plug-in allows the insertion of up to 32 mono/16 stereo EXS24 samplers in the uppermost Insert slots of Aux channel strips in the TDM mixer. Ensuing Insert slots allow the sampler output signals to be further treated by TDM effect plug-ins.

**Note:** The EXS24 TDM is available as a mono or stereo plug-in, but not as a multichannel plug-in.

The maximum number of available Aux channels is 64. Any established configuration of the first 32 Aux channel strips will remain as is.
**EXS24 TDM or ESB TDM?**

If you want to process the output signals of (up to 32) EXS24 TDM samplers with TDM effect plug-ins exclusively, please read the EXS24 TDM section directly below. Bear in mind that if you want to use the EXS24 TDM exclusively, there is no need to activate DTDM in addition to the DAE.

In scenarios where you wish to utilize Logic’s native audio system (DTDM)—in addition to your TDM system—please refer to “ESB TDM” on page 24. The information found in this section is also relevant to the routing of natively processed signals from other Logic or Audio Unit instruments into the TDM mixer.

**EXS24 TDM**

If no Aux Objects exist in your TDM Mixer within Logic, please create them in your song.

**To create TDM Aux Objects manually:**

1. Open Logic’s Audio Mixer, by choosing Audio > Audio Mixer.
2. In the Audio Mixer window choose New > Audio Object to create a new Audio Object.
3. Double-click the newly-created Audio Object icon, so that the channel strip appears.
4. Now, go to the Object Parameter box, and set the **Channel** parameter to **Aux**.
5. The **Device** parameter needs to be set to DAE. The generic Audio Object will now operate as a TDM Aux Object.

**Note:** Experienced TDM users use Aux Objects (with busses used as inputs) rather than Bus Objects, as these feature the advantage of aux sends to other effects busses.

**To insert the EXS24 TDM:**

- Click-hold on the uppermost Insert slot of a TDM Aux Object. A pop-up menu appears, allowing you to select the EXS24 TDM.
Note: Should you require a stereo instance of the EXS24 TDM, please press Option while inserting the plug-in, or choose a stereo Aux Object. Select the Stereo EXS24 TDM version from the menu.

In the example shown, multiple EXS24 sampler instances have been inserted into the Aux Objects 9–24.

Note: Please note that the icon checkboxes must be checked in each Aux Object’s Parameter box. This allows the Aux channels to be selected as tracks in the Arrange window.

To play the EXS24 TDM sampler inserted in the Aux 1/2 channel:

- Select the corresponding Aux 1/2 track in the Arrange window. When the track is selected, you will be able to play and record the sampler instance.

Subsequent Insert slots within the Aux Object—beginning with the second Insert slot—allow the insertion of TDM effect plug-ins, for treatment of the sampler’s output signal. Further processing options via sends (leading to the effect busses) and output routings behave as per usual. The input routing parameter has no effect, this is as per using HTDM or TDM instruments (such as Virus TDM).
EXS24 samples reside in the computers RAM (although large samples can also be streamed from hard disk, in realtime). Should any Instruments loaded into multiple EXS24 instances use the same samples, RAM usage is unaffected. This intelligent memory management ensures that any given sample is only loaded once into memory. This allows the use of the same sound program (sampler instrument) or some/all of the same samples in several EXS24 instances, with minimal impact on system resources.

Another point to bear in mind is that the EXS24's sound generation engine is calculated by the computer, and will therefore cause some CPU load. If you attempt to simultaneously run numerous polyphonic EXS24 instances, you may notice a degree of computer slowdown.

As an expected performance example: a Macintosh G4/800 (with sufficient RAM), running 24 sampler instances, and using a combined 64 voices of polyphony should not pose a problem.

**ESB TDM**

The ESB TDM allows the outputs of Logic’s DTDM “native” audio engine to be routed into the inputs of the TDM mixer. This is done via Digidesign StreamManager. You can activate the DTDM driver via the Audio > Audio Hardware & Drivers menu.
Although we recommend using the default settings, it may be useful to set the Process Buffer Range parameter to Large in order to avoid disturbing the DAE's calculation of TDM audio tracks. Changing this setting will aid system performance, allowing the playback of the maximum number of audio tracks to remain achievable. You should only activate the 64 Busses feature if absolutely required. When disengaged, you will reduce the strain on the CPU, which frees up resources that can be used for native instrument and plug-in processing.

**Note:** Further information on the parameters of the Drivers pane can be found in the section “Drivers” on page 8.

Should your Autoload Template currently contain a mixer for a Core Audio device, select all of this device's Audio Objects ([Audio > Audio Mixer]) and switch the Device parameter to Direct TDM:

If no mixer exists in your Autoload Template, generate one for the virtual DTDM hardware. For more information, see “Generate Audio Mixer” on page 19.
Dependent on the number of any given Object type required, your DTDM mixer could look something like this:

This mixer example features six Audio Track Objects, two Bus Objects, two Audio Instrument Objects, and two stereo sums. It is possible to engage up to 255 Audio Track Objects and 64 Bus Objects.

The eight output signals of this mixer are routed into the TDM mixer, courtesy of StreamManager technology. The output signals are received by the virtual ESB TDM inputs—chosen as Inputs on the TDM Aux Objects. In the following example, Aux channels 1–8 have been set up in this fashion:
Within mono Aux Objects, you can select the desired output channel of the DTDM mixer (ESB 1–8). Stereo Aux channels can be set to input channel pairs ESB1–2, 3–4, 5–6, and 7–8. Please take a closer look at the available inputs:

Please note that Logic handles mono and stereo channel settings separately. This means that you can set up the ESB inputs for eight mono channels, and then switch the Audio Objects to stereo operation. Once the desired DTDM output channels are set appropriately for each Aux Input, save your Autoload Template. This will allow you to switch quickly between mono and stereo setups, without needing to reset the settings each time.

Copying the Mixer Setup
Each song separately memorizes the settings for each audio hardware device supported by Logic. In order to copy the mixer setup from, say, a Core Audio device to DTDM, select the Audio > Audio Configuration menu option. Once the Audio Configuration window has launched, select Core Audio in the local device menu. Now, copy the setup using the Edit > Copy command, select DTDM in the device menu, and choose Edit > Paste. You can even copy and paste between songs.

The easiest way to load a song that originated on a Core Audio system into a DAE/DTDM system:

1. Deactivate DAE and ensure that DTDM is active.
2. Ensure that the Universal Track Mode setting is the same for both Core Audio on the song's origin system and DTDM on your system.
3. Open this song, and you will be asked for automatic conversion to DTDM. When the converted song has loaded, reactivate DAE.
4. Relaunch Logic, and create the required DAE Audio Objects.

Note: Full functionality of DTDM requires that the ESB inputs must be actively chosen in DAE Aux Objects.
Audio Export and Import

Logic has the ability to export and import song contents using the OMF and AAF file formats.

Typically, the OMF (Open Media Framework, also known as OMFI—Open Media Framework Interchange) or AAF (Advanced Authoring Format) formats are used for data exchange with Digidesign ProTools software. The OMF file format only support the exchange of audio data (audio media and the usage of this audio media in a project)—MIDI and automation data will simply be ignored when using the export functions.

OMF Export
To export the current song as an OMF file, select File > Export > Export Song as OMF File. This will launch a dialog that displays the following options:

OMF File Version
This allows you to export the file in OMF Version 1 or Version 2 format. You will usually choose Version 2 here. Version 1 is only useful for backwards compatibility with older software versions.

Include Audio
If this box is checked, all exported audio files will be integrated into the OMF file itself. If unchecked, only file references are written to the OMF file. If this method is used and you wish to copy the OMF file to another hard disk, you need to ensure that all referenced audio files are also copied.

Note: Although this can result in a very large file, and can make file export times lengthy, we recommend to activate this option.

Convert interleaved to split stereo
As some applications don't support interleaved stereo files, Logic can convert interleaved stereo files to split stereo (useful when exporting an OMF file for a ProTools session, for example). Check this box if this is the desired behavior. Note that this only works if the Include Audio option is checked (recommended).
Pan tracks
If this box is checked, Logic adds information to the OMF file which sets the panning of
the exported tracks as they appear in Logic itself (Stereo tracks in Universal Track Mode
are exported as two mono tracks. Assuming this option is checked, the left mono track
is panned to the left and the right one, to the right).
**Warning:** This does not work with OMF Tool or DigiTranslator. Don’t check this box if
you are using OMF Tool to convert the OMF file into a ProTools session, as it is
unsupported by OMF Tool.

Convert 24 bit files to 16 bit
This setting converts all 24 bit files to 16 bit using the Dithering type described below.
This might be necessary when using older versions of ProTools.

Dithering Type
When exporting 24 bit recordings into 16 bit files and the audio files are included in the
OMF file, dithering is recommended.

Executing Export
After pressing the OK button, a file dialog allows you to specify the destination folder
of the OMF file to be generated. Choose a location and you’re done. If you have
checked the **Include Audio** option, Logic will display a progress bar for each exported
audio file.

OMF Import
The File > Import menu option will open a file selector, which allows you to choose OMF
files.

After selecting a file, a further dialog allows you to choose the location for the audio
data extracted from the OMF file.

Following confirmation of this dialog, the OMF file is imported into the currently open
song—new audio tracks are generated for every track contained in the OMF file, and
the audio parts are placed appropriately on these tracks.

AAF Export
To export the current song as an AAF file, choose File > Export > Export Song as AAF file.

This will export all used audio files and Regions with reference to tracks and position,
volume automation included.

AAF Import
The File > Import menu option will open a file selector, which allows you to choose AAF
files.
This chapter provides you with tips and tricks on running Logic Pro with TDM hardware.

You will find information about the differences when using ESB TDM on Mac OS 9 or Mac OS X, along with tips on importing songs from other systems. You will also be introduced to the use of DAE, DTDM, and Core Audio simultaneously, and to the System Performance window. To close, you will learn about different bounce strategies.

Note: We have included the information on Mac OS 9 to assist existing users who have upgraded to Logic Pro 7. Version 7 only runs on Mac OS X.
ESB TDM Differences Mac OS 9 and Mac OS X

How things used to work in Mac OS 9:
The eight possible output signals of the DTDM mixer were routed into the TDM mixer, courtesy of DirectConnect technology. The output signals were received by the ESB TDM plug-ins inserted in the uppermost Insert slots of the TDM Aux Objects.

Within the ESB TDM Plug-in window, you could select the desired output channel of the DTDM mixer (Outputs 1–8). ESB TDM plug-ins inserted in stereo Aux Objects could be set to output channel pairs 1–2, 3–4, 5–6, and 7–8.
Using songs created in Logic Pro for Mac OS9 in Mac OS X:
If you are opening a song created on an Mac OS 9 system, Logic Pro (for Mac OS X) will automatically create the correct ESB TDM inputs (with inserted ESB TDM plug-ins) in the dedicated TDM Aux Objects. The plug-ins themselves remain crossed out. If you leave them alone, you will be able to reopen the songs on Mac OS 9 systems without problems.

How to Import Songs from Mac OS 9 Systems
DAE only
If you used only the DAE, importing a song is quite easy: Simply open the song, all TDM plug-ins will automatically be inserted correctly, if all of them are available on your TDM system.

DAE and DTDM
• DAE: As mentioned, an automatic conversion from ESB plug-ins (Direct Connect) to ESB inputs will take place.
• DTDM: All Logic plug-ins and instruments will appear just fine within DTDM. If there are Audio Unit versions of VST plug-ins installed, they will automatically be converted, complete with all settings and automation data. If the Audio Unit version of the VST plug-in has no settings that are compatible with its VST counterpart, there will be no automatic conversion—although the plug-in itself will load and work.

DAE and ASIO (or other native audio engine)
• DAE: As above
• ASIO or other native native audio engine: If there are Audio Unit versions of VST plug-ins installed, they will automatically be converted, complete with all settings and automation data. If the Audio Unit version of the VST plug-in has no settings that are compatible with its VST counterpart, there will be no automatic conversion—although the plug-in itself will load and work.
How to Import Native Songs from Any System
If you simply want to use the native processing capabilities of Logic, start Logic Pro using Core Audio—with the standalone Digidesign Core Audio driver for your TDM hardware activated.

You will be asked if you’d like an automatic conversion if the song was created on a non Core Audio system, provided that the Universal Track Mode setting is the same on both systems.

Be aware of problems with incompatible plug-ins and/or settings, as mentioned above.

If you want to work further on this song, with the addition of TDM plug-ins and instruments, start Logic Pro with DTDM only, as described earlier. You will be asked if you’d like an automatic conversion, provided that the Universal Track Mode setting is the same on both systems.

Be aware of problems with incompatible plug-ins and/or settings, as mentioned above.

Follow the advice given earlier about reactivating DAE, the creation of further DAE audio objects, and actively choosing the ESB Inputs of DAE Aux objects.

Using DAE, DTDM, and Core Audio Simultaneously
We strongly recommend that you do not attempt to use more than two audio engines simultaneously within Logic Pro. The strain on the PCI bus will cause too many problems, and will generate a number of DAE error messages.

Your first choice should be DAE in conjunction with DTDM. If necessary, choose DAE and Core Audio.

System Performance and TDM DSP Usage
The System Performance window does not reflect any native processing via the Digidesign StreamManager in the DAE. Bear in mind that there may be heavy use of the CPU due to the insertion of numerous ESX24 TDM or third party HTDM (Host TDM) plug-ins, in addition to the DTDM or Core Audio processing.

An exception to the rule that all processing in TDM is performed by the DSP chips of the TDM hardware are plug-ins and instruments that are routed to the CPU via the Digidesign StreamManager, including: the ESX24 TDM, HTDM instruments and plug-ins. The eight ESB TDM streams are provided by the StreamManager.

The StreamManager uses one of the TDM hardware DSPs. Up to 32 streams are possible if working at 44.1/48 kHz, 16 at 88.2/96 kHz and only six at 176.4/192 kHz. Only one StreamManager instantiation is possible.
The number of TDM streams used by the DAE is displayed in the TDM DSP Usage window (Audio > TDM DSP Usage). Check out this window to see how many streams are used, and how many are available for further EXS24 TDM or HTDM instruments and plug-ins.

<table>
<thead>
<tr>
<th>TDM DSP Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

**Bounce Strategies**

The easiest way to perform a stereo bounce is to choose File > Bounce. This will open the Bounce dialog for Outputs 1/2 of your primary audio hardware. It is highly recommended that you use the first output pair of your audio device for main playback duties.

**Note:** If you are using other Output Objects for primary playback duties, please use the Bounce button on these Objects.

You can set the file format, bit depth and sample rate of the bounce file in the Bounce dialog. More information about other parameters can be found in the Logic reference.

**Note:** Ensure that your Master Object is set to 0 dB, to achieve the full resolution and maximum gain while bouncing.

**DAE**

You will be able to perform realtime bounces in mono, stereo, and in all surround formats that Logic Pro offers. Offline bounces are not possible when you use the DAE.
Please bear in mind that none of the TDM surround features are available in Logic Pro. You will need to use the Bounce button of each desired Output Object for all bounce operations, other than those for Output 1-2 (or surround) bounces.

**DTDM**

If using the DTDM Output Objects, you will have nearly all of the offline and online bouncing features afforded by Core Audio. The only omission is that surround bouncing is limited to eight channels, given the maximum of eight ESB streams. This means that 7.1 surround bounces can be performed without problems when you use the DTDM. For more information on Logic’s surround features, please refer to the Logic reference.

**Note:** You can also use Logic’s Freeze facility to perform individual offline bounce processes for each track. To Freeze, simply click on the Freeze button (the ice crystal) of the desired audio track(s) in the Arrange window Track List. The next time you hit Play, Logic will freeze the tracks, saving massive amounts of processing power. When you use the DAE, the Freeze function can not be used. For more information on Logic’s Freeze function, please refer to the Logic reference.
Glossary

**AAF**  Abbreviation for Advanced Authoring Format. This file format, typically used for data exchange with Digidesign ProTools software, can be imported and exported by Logic. It allows multiple audio tracks to be imported, with reference to tracks and Region position, volume automation included.

**amplifier**  Device which controls the level of a signal.

**amplitude**  This term is used to describe the amount of a signal. If you have an audio signal, amplitude refers to the sound's volume, measured in decibels (dB).

**analog signal**  A description of data that consists of a constantly varying voltage level, that represents audio information. Analog signals must be digitized, or captured, for use in Logic. Compare with digital.

**Arrange window**  The heart of Logic. The primary working window of the program where Audio and MIDI Regions are edited and moved to create a song arrangement.

**attenuate**  To lower an audio signal's level.

**audio file**  Any digital recording of sound, stored on your hard drive. You can store audio files in the AIF, WAV and Sound Designer II formats. All recorded and bounced WAV files are in Broadcast Wave format.

**Audio Instrument**  Logic supports the use of software based instruments. Software instrument plug-ins are inserted into Audio Instrument Objects. Software instrument recording takes place on Audio Instrument tracks in the Arrange window. Playback of these tracks is routed via the Audio Instrument Object.

**audio interface**  Device needed to get sound into and out of your computer. An audio interface converts digital audio from your computer to analog waves that speakers can broadcast, or, in the other direction, an audio interface converts analog waves into digital audio your computer can work with.

**Audio Mixer**  An Environment layer that shows all Audio Objects of a song. The Audio Mixer is used for mixing multiple audio channels in real time. The Audio Mixer is also known as Environment Mixer.
**Audio Object**  Audio Objects are found in Logic's Environment. They are the “building blocks” of the Audio Mixer. When expanded, Audio Objects look just like channel strips. Audio Objects tell Logic where to send audio signals. The following Audio Object types are available: Audio Track Object, Input Object, Audio Instrument Object, Bus Object, Output Object, Master Object, Aux Object.

**Audio Region**  Chosen area of an audio file which is registered in the Audio window for use in the song and, can be placed on audio tracks in the Arrange window, just like a MIDI Region can be placed on MIDI tracks. Audio Regions are aliases (or pointers) to portions of audio files. They can be as short as a single sample, or as long as the audio file itself. You can use all of Logic's tools to edit Audio Regions. Editing is non destructive on the original audio file, as the Region is only an alias of the audio file. See also Region and MIDI Region.

**audio track**  A track in Logic's Arrange window that is used for playback, recording and editing of Audio Regions.

**Audio Track Object**  Audio Object in the Environment's Audio layer. Used to playback audio tracks in Logic's Arrange window. All data on the audio track is routed to the Audio Object, that was assigned in the Arrange window's Track List menu.

**Audio Units (AU)**  Audio Units is the standard format for real-time plug-ins running on Mac OS X. It can be used for audio effects and software instruments. The Audio Unit format is part of the Mac OS X operating system. Once installed, Audio Unit plug-ins can be accessed by all programs simultaneously. Logic supports all Audio Unit format plug-ins.

**Audio window**  Logic window used for a number of audio file handling and conversion tasks.

**Autoload Song**  Song with your favorite settings and preferences. It loads automatically when you launch Logic, and serves as a starting point for your songs and projects.

**automation**  Automation is the ability to record, edit, and play back the movements of all knobs, controls and buttons, including volume faders and pan, EQ, and Aux send controls plus almost all effect and instrument plug-in parameters.

**Aux Object**  Audio Object in the Environment's Audio layer. Aux Objects are similar to the Bus Objects, but are more flexible. Unlike Bus Objects Aux Objects also have Sends of their own, allowing you to form complex signal paths.

**bar**  In musical notation, a bar is a measure that contains a specified number of beats, and establishes the rhythmic structure of a musical piece.
**Beat Mapping track**  Component of the Global tracks that helps to make a rhythmically meaningful display of recordings that do not correspond to a strict tempo throughout. It does this by redefining the bar positions of existing musical events, without changing their absolute time position, thereby preserving the audible result with its original timing.

**bit depth**  The number of bits a digital recording or digital device uses. The number of bits in each sample determines the theoretical maximum dynamic range of the audio data, regardless of sample rate. Also known as bit resolution, word length or bit rate.

**bit rate**  See bit depth

**bit resolution**  See bit depth

**bounce**  To process recorded or streamed MIDI and/or Audio Regions with any applied effects, such as delay or compression, combining them into one audio file. In Logic, you can choose between Realtime and Offline bouncing. Offline bouncing is faster, but doesn't allow you to apply live automation or record real time audio input.

**Bounce button**  You can bounce the output of any Output Object to an audio file by clicking the Object’s Bounce button. See also bounce.

**bus**  The term bus is used to describe a send/return routing scheme for audio channels. In Logic, effects can be sent to/from Bus Objects for processing or submixing tasks.

**Bus Object**  Audio Object in the Environment’s Audio layer. Usually used to route the signal of an individual send bus to Output Objects. See also bus.

**bypass**  To deactivate a plug-in. Bypassed plug-ins do not drain system resources. In Logic you can bypass a plug-in by either clicking its Bypass button in the plug-In window or by Option-clicking on the appropriate plug-in slot.

**cable**  In Logic the term cable is used to describe the virtual cables that represents the MIDI connection between two Environment Objects.

**CD Audio**  Short for Compact Disc—Audio; current standard for stereo music CDs: 44.1 kHz sampling rate and 16 bit depth.

**channel strip**  A channel strip is a virtual representation of a channel strip on a mixing console. Each channel strip contains a number of similar controls, such as a Mute button, Volume fader, Pan/Balance knob, Output selector and Bus and/or Insert slots.

**checkbox**  A small box. You click a checkbox to select or deselect an option.

**Clipboard**  The Clipboard is an invisible area of memory, into which you cut or copy selected objects, using the Edit menu. From there, you can paste these objects to different positions. Logic’s Clipboard spans all songs, allowing it to be used to exchange objects between songs.
controller  MIDI data type. As examples; sliders, pedals or standard parameters like volume and panning. The type of command is encoded in the first data byte, the value in the second data byte.

Core Audio  Standardized audio driver system for all Macintosh computers running version 10.2 or higher. Core Audio is an integral part of Mac OS X, allowing access to all audio interfaces that are Core Audio compatible. Logic is compatible with any audio hardware that offers Core Audio drivers.

Core MIDI  Standardized MIDI driver system for all Macintosh computers running Mac OS X version 10.2 or higher. Core MIDI is an integral part of Mac OS X, allowing the connection of all MIDI devices that are Core MIDI compatible.

DA converter or DAC  Short for digital/analog converter; a device that changes an analog signal into a digital signal.

DAE  DAE is the abbreviated form of Digidesign Audio Engine. This is the driver software for many Digidesign cards, and is primarily used for the operation of TDM hardware and/or access to their on-board DSP chips.

DAW  Acronym for Digital Audio Workstation. A computer used for recording, mixing and producing audio files.

dB  Abbreviation for decibels, a unit of measurement that describes the relationships of voltage levels, intensity or power, particularly in audio systems.

default  The preset parameter value.

destructive  Destructive audio processing means that the actual data of an audio file is changed, as opposed to just editing peripheral or playback parameters.

dialog  A window containing a query or message. It must be cancelled or replied to before it will disappear and allow you to continue.

digital  A description of data that is stored or transmitted as a sequence of ones and zeros. Most commonly, refers to binary data represented using electronic or electromagnetic signals. All files used in Logic are digital. Also see analog for comparison.

disclosure triangle  A small triangle you click to show or hide details in the user interface.

distortion  The effect produced when the limit of what can be accurately reproduced in a digital signal is surpassed, resulting in a sharp, crackling sound.

distributed audio processing  See Logic Node application.
**drag & drop** Grabbing objects with the mouse, moving them, and releasing the mouse button.

**driver** Drivers are software programs that enable various pieces of hardware and software to be recognized by other programs in a computer, and also to have the appropriate data routed to them in a format they can understand. In Logic, you can use the Preferences > Audio > Drivers panel to select and configure your audio hardware drivers. If you do not have the proper driver installed, your computer may not recognize or work properly with a given piece of hardware.

**DSP (digital signal processing)** In Logic, the mathematical processing of digital information to modify a signal. An example is the Insert slot of channel strips, which assigns DSP effects such as dynamic compression and delay to a channel's signal.

**DTDM Mixer** Logic Pro supports a number of Digidesign hardware devices via Direct TDM. The DTDM mixer is created in Logic's Environment window, and allows the use of Logic "native" effects and instruments with suitable Digidesign hardware.

**dynamics** Refers to changes in volume or other aspects of a piece of music over time.

**dynamic range** The dynamic range of a sound system is the difference in level between the highest signal peak that can be reproduced by the system (or device in the system) and the amplitude of the highest spectral component of the noise floor. The dynamic range is the difference between the loudest and softest signals that the system can reproduce. It is measured in decibels (dB). See decibels.

**editor** Window for editing MIDI or audio data. Logic offers the Hyper, Matrix and Score editors for MIDI event data, and the Sample Editor for audio data.

**effect** A type of software algorithm that lets you alter the sound of a track in a variety of ways. Logic includes a set of EQ, dynamics, time-based, modulation and distortion effects in Logic's native and Audio Unit plug-in formats.

**Environment** The Environment is Logic's brain: it graphically reflects the relationships between hardware devices outside your computer and virtual devices within your computer. Beyond basic input and output handling, the Environment can be used to process MIDI data in real-time, and can even be used to create processing "machines", such as virtual rhythm generators and step sequencers or complex synthesizer editors.

**Environment layer** A place in the Environment, used to organize Objects and making usage easier. Objects of the same type (Audio Objects, for example) are generally placed on the same layer.

**ESB TDM** The ESB TDM connects your TDM hardware with Logic's audio engine. This allows your computer's CPU to perform processes in Logic's native mixer, including audio track playback, the use of software-based instruments and effect plug-ins.
**export**  To create a version of a file, such as a Logic song, in a different format that can be distributed and used by other applications.

**Freeze function**  The Freeze function performs individual offline bounce processes for each “frozen” track, saving almost 100% of the CPU power used for software instruments and effect plug-ins. All plug-ins of a track (including software instrument plug-ins, if applicable, along with all related automation data) are rendered into a “Freeze file.” You can use the Freeze function on individual Audio or Audio Instrument tracks.

**grab (an object)**  Positioning the mouse cursor over an object, then pressing and holding the mouse button down.

**hierarchical menu**  Structured menus where choosing an individual entry opens a submenu.

**importing**  The process of bringing files of various types into a Logic project or song. Imported files can be created in another application, captured from another device, or brought in from another Logic project.

**Input Object**  Audio Object in the Environment’s Audio Layer. The Input Object represents the physical inputs of your audio interface and helps managing audio from your audio interface into Logic.

**Insert slot**  A point on Logic’s Mixers where you can patch in (insert) an effect plug-in. All audio channel types in Logic’s Track and Audio Mixers (except the Master Object) offer effect insert slots.

**interface**  1) A hardware component such as a MIDI or audio device that allows Logic to “interface” (connect) with the outside world. You need an audio or MIDI interface to get sound/MIDI into and out of your computer. Also see audio interface. 2) A term that is used to describe Logic’s graphical elements that can be interacted with. An example would be the Arrange window, where graphical interface elements such as Regions are interacted with to create an arrangement, within the overall Arrange interface.

**key command**  Function which can be executed by pressing a specific key (or key combination) on your computer keyboard or MIDI controller.

**latency**  You may notice a delay between playing your keyboard and hearing the sound. This is a form of latency. A variety of factors contribute to latency including audio interface, audio and MIDI drivers. One factor under you control, however, is the I/O buffer size, which is set in the Audio > Audio Hardware & Drivers preferences.

**local menu**  Menu in a window that only contains functions that are relevant to that particular window.
**Logic Setup Assistant** A utility that guides you through the process of setting up your Macintosh, audio and MIDI hardware to work with Logic. The Logic Setup Assistant can be run at any time by choosing the Preferences > Start Logic Setup Assistant menu item.

**main menu bar** The bar at the top of the computer screen, offering global functions such as opening, saving, exporting or importing songs. It does not offer access to local functions.

**MIDI** Abbreviation for Musical Instrument Digital Interface. Standardized, asynchronous, serial and event-oriented interface for electronic musical instruments. MIDI is an industry standard that allows devices such as synthesizers and computers to communicate with each other. It controls a musical note's pitch, length, and volume, among other characteristics.

**MIDI Region** Data container for MIDI events which is shown in the Arrange window as a named horizontal beam. In earlier Logic versions MIDI Regions were called sequences.

**mixing** The process of shaping the overall sound of a song by adjusting the volume levels, pan positions, adding EQ and other effects, and using automation to dynamically alter aspects of the song.

**modifier key** Computer keyboard keys used in conjunction with alphabetical keys to change functionality. Modifier keys include; Control, Shift, Option and Command.

**mono** Short for monophonic sound reproduction. The process of mixing audio channels into a single track, using equal amounts of the left and right audio channel signals. Compare with stereo.

**MTC** See MIDI Time Code.

**mute** Switch off an Audio Object or track's audio output. You can mute a track by clicking the Track Mute button in the Track List. The output of an Audio Object is disabled by clicking the Mute button at the bottom of the channel strip.

**native** Native refers to host-based processing of effects and software instruments in Logic. The computer CPU “natively” calculates the effects and instruments. Native also refers to Logic's plug-in format, which is different to the Audio Unit format. Logic "native" plug-ins only work in Logic.

**Object** If capitalized, the term Object is used to refer to the graphical representation of all elements in Logic's Environment. These elements can be used to create and process MIDI data in real-time, and can even be used to create processing "machines", such as virtual rhythm generators or step sequencers. Examples for Objects are Instruments, Multi Instruments, Faders, Arpeggiators and others. In the Environment's Audio layer you also find Objects used to process audio data. These Objects are correspondingly named Audio Objects. Also see Audio Objects.
OMF  Abbreviation for Open Media Framework, also known as OMFI—Open Media Framework Interchange. This file format, typically used for data exchange with Digidesign ProTools software, can be imported and exported by Logic. The OMF file format only supports the exchange of audio data (audio media and the usage of this audio media in a song). MIDI and automation data will simply be ignored when using Logic’s export function.

Open TL  Abbreviation for Open Track List. This file format, typically used for data exchange with Tascam hard disk recorders, such as the MX 2424, can be imported and exported by Logic. The Open TL file format only supports the exchange of audio data (Audio Regions and their positions on tracks). MIDI and automation data will simply be ignored when using Logic’s export function.

option  1) Alternative function, often in the form of a checkbox, sometimes also available as a menu entry. 2) Modifier key, in Windows terminology this key is also known as Alt key.

Output Object  Audio Object in Logic’s Environment controlling the output level and pan/balance for each output on your audio interface. They are assigned to a specific hardware output in their Object Parameter box.

pan, pan position  The placement of mono audio signals in the stereo field, by setting different levels on both sides.

Pan control  Rotary knob directly above the Volume control on mono Objects that determines the position of the signal in the stereo image.

Parameter box  Field on the left side of Logic’s windows used to adjust the parameters of the selected Regions or Objects.

playback  Playing an Audio or MIDI Region or an entire arrangement, allowing you to hear it.

plug-in  Software application that enhances the functionality of the main program (in this case, Logic). Logic’s plug-ins are typically software instruments or effects.

Plug-in window  A window that launches when a plug-in is inserted, or the Insert/Instrument slot is double-clicked. Allows you to interact with the plug-in parameters.

Preferences window  A window that is accessed via the Logic > Preferences menu. All Logic preferences can be set in this window.

project  In Logic, the top-level folder that holds all media associated with a song, including audio files, Sampler Instruments and samples, Video and Settings of various kinds.
RAM  Abbreviation for random-access memory. A computer's memory capacity, measured in megabytes (MB), which determines the amount of data the computer can process and temporarily store at any given moment.

Region  Regions can be found in the tracks of the Arrange window: They are rectangular beams that act as containers for audio or MIDI data. There are three different types of Regions: Audio Regions, MIDI Regions and Folder Regions. Also see: Audio Region, MIDI Region and Folder.

routing  Generally refers to the way audio is sent through processing units. Also often used to describe specific input and output assignments.

sample  A digital recording of a sound at a particular instant in time.

sampler  Device used for sampling. In Logic, this generally refers to the EXS24 software-based sampler.

sample rate  When an analog audio signal is converted to a digital signal, this term refers to the number of times per second the audio file is sampled. Logic can record and edit audio at sample rates ranging from 44.1 kHz (44,100 times per second) up to 192 kHz (192,000 times per second).

scroll bar and scroll box  Gray beam at the edge of a window. A movable box inside the beam is used to select the displayed song section in the window.

scrubbing  On tape machines: manually moving the tape across the tape head. In a sequencer: manually moving the Song Position Line through the song, triggering playback of MIDI events. In Logic: you can scrub through the song by starting playback, grabbing the bottom third of the Bar Ruler and moving the mouse to the left or right.

send  Abbreviation for auxiliary sends. An output on an audio device used for routing a controlled amount of the signal to another device. Sends are for example often used to send several signals to the same effect, which is rather advisable for computationally-intensive effects such as reverb.

sequencer  A sequencer is a computer application that allows you to record both digital audio and MIDI data and blend the sounds together in a software mixing console. There are editing tools that let you control every aspect of the production, down to the finest details. Effect processors and software instruments are increasingly being added to these applications. Modern sequencers such as Logic now can fulfill many, if not all, functions that were only possible in the most expensive and well-equipped recording studios a decade ago.

setting  1) A parameter value. 2) A set of plug-in parameter values that can be loaded, saved, copied or pasted via the Settings menu. A plug-in setting is also known as preset. Also see preset and Settings menu.
**Settings menu**  Accessible via the Arrow button found in the gray header at the top of all plug-in windows. Allows you to save, load, copy and paste settings: the parameter values of effects and software instruments.

**shelving EQ**  EQ type that allows reducing or increasing the frequency range above or below the specified frequency.

**side chain**  A side chain is effectively an alternate input signal—usually routed into an effect—that is used to control an effect parameter. As an example, you could use a side chained track containing a drum loop to act as the control signal for a Gate inserted on a sustained pad track, creating a rhythmic gating effect of the pad sound.

**Snap menu**  A pull-down menu found at the top of all linear editing windows in Logic. Selection of items in the menu will cause events or Regions to “snap” to the specified value when moved.

**software instrument**  Logic’s software counterpart to a real sound source or a sampler or synthesizer module.

**Solo tool**  Click-holding on individual Regions or events with the Solo tool temporarily allows them to be heard in isolation. All other objects are muted.

**song**  Main Logic file, containing all MIDI events and parameter settings (including mixer automation data) plus information about the audio files to be played.

**stereo**  Short for stereophonic sound reproduction of two different audio channels. Compare with mono.

**synthesizer**  A device (hardware or software) that is used to generate sounds. The word is derived from early attempts with mechanical and electronic machines to emulate (or synthesize) the sounds of musical instruments, voices, birdsong and so on. Logic features several software synthesizers, including; the ES1, ES2, EFM 1, ES E, ES P and ES M.

**toggle**  To switch between two states such as on or off (applies to windows, parameter values and so on).

**Touch Tracks**  An Environment Object that allows MIDI Regions to be assigned to, and triggered by, individual MIDI note events. This enables you to assign a number of musical phrases to different MIDI keyboard keys, and trigger (or record) them in real-time, making the process of arrangement faster and more intuitive.

**track**  A horizontal row in the Arrange window that contains either Audio or MIDI Regions that can be played back over time. Each track has a specified destination that data is routed to. Logic allows hundreds of tracks to be used in a song.
Track List  Situated to the left of the Arrange window's working area. Displays the Objects assigned to various tracks as well as the Track buttons.

window class  Status of the window as a float window or a normal window. Float windows always “float” in the foreground and can not be hidden by normal windows. Also see float window.

word length  See bit depth.
Index

A
AAF 30, 37
importing 30
adapting song produced with other hardware 14
aftertouch 37
amplifier 37
amplitude 37
analog 37
Arrange window 37
attenuating 37
AU
Audio Instrument 37
Audio Mixer 37
Audio Mixer (generating) 19
Audio Object 38
Audio Track Object 38
Aux Object 38
Bus Object 39
deleting 17
generating manually 22
Input Object 42
AudioSuite plug-in 19
audio track (total number) 20
Audio Track Object 38
Audio Unit. See AU
Audio window 38
Autoload Song 38
automation 38
Aux Object 38

B
bar 38
Beat Mapping track 39
bit depth 12, 39
changing 18
converting 18
bit rate. See bit depth
bit resolution. See bit depth
bounce 39
Bounce button 39
bouncing 35
bus 39

Bus Object 39
bypass 39

C
channel strip 39
checkbox 39
Clipboard 39
troller 40
Core Audio 8, 9, 40
I/O Buffer Size parameter 9
Larger Disk Buffer option 11
Max. Number of Audio Tracks 10
Recording Delay parameter 10
64 Busses option 10
Software Monitoring option 11
24 Bit Recording option 11
Universal Track Mode 10
Core MIDI 40

D
DAC 40
da converter 40
DAE 12
Global Bit Depth parameter 12
MIX Card Type 12
PT HD Type 12
Release in Background if Stopped parameter 13
supported hardware 8
TDM Setup Indicator 12
DAW 40
dB
decibel. See dB
deleting Audio Object 17
destructive 40
dialog 40
Digidesign Audio Engine. See DAE
Digidesign Hardware Setup dialog 14
digital 40
digital audio workstation. See DAW
digital signal processing. See DSP
Direct Connect 33
Direct TDM 8, 9
Larger Disk Buffer option 11
Max. Number of Audio Tracks 10
64 Busses option 10
Universal Track Mode 10
Dithering Type 30
driver 8, 41
Core Audio 8, 9
DAE 8, 12
Direct TDM 8, 9
switching off on start-up 9
DSP
dynamic range 41

E
editor 41
Environment 41
layer 41
ESB TDM 24, 41
copying mixer setup 27
differences Mac OS 9 and Mac OS X 32
exporting 29
AAF 30
OMF 29
Convert 24 Bit Files to 16 Bit option 30
Convert Interleaved to Split Stereo option 29
Dithering Type 30
Include Audio option 29
OMF File Version option 29
Pan Tracks option 30
EXS24 TDM 22
inserting 22
intelligent memory management 24
playing 23

F
Freeze 36
Freeze function 42

G
Global Bit Depth parameter 12

H
hardware
setting up 7
simultaneous use of multiple audio cards 7
HTDM plug-in 17, 23, 34

I
I/O Buffer Size parameter 9
importing 29
AAF 30
from Mac OS 9 system 33
native song 34
OMF 30
Input Object 42
interface 42

L
Larger Disk Buffer option 11
latency 42

M
Max. Number of Audio Tracks 10
Maximum Scrub Speed parameter 10
MIX Card Type 12
modifier key 43
mute 43

N
native processing 43

O
OMF format 29
Output Object 44

P
Pan control 44
Parameter box 44
playback 19, 44
Plug-in window 44
Premiere plug-in 19
pressure 44
Process Buffer Range parameter 13
PT HD Type 12

R
RAM 45
Recording Delay parameter 10
Release in Background if Stopped parameter 13
Rewire Behaviour parameter 13
routing 45
RTAS plug-in 17

S
Sample Editor 19
sample rate 12, 45
Scrub Response parameter 13
sequencer 45
setting 16, 45
copying 16
loading 17
pasting 16
saving 16
side chain 46
simultaneous use of multiple audio cards 7
simultaneous use of TDM & other hardware 19, 34
64 Busses option 10
Software Monitoring option 11
stereo recording 16
StreamManager 34
synthesizer 46
System Performance window 34
<table>
<thead>
<tr>
<th>T</th>
<th>TDM Mixer plug-in 18</th>
</tr>
</thead>
<tbody>
<tr>
<td>differences to native system 15</td>
<td>TDM Setup Indicator 12</td>
</tr>
<tr>
<td>plug-in 16</td>
<td>toggle 46</td>
</tr>
<tr>
<td>setting 16</td>
<td></td>
</tr>
<tr>
<td>side chain 17</td>
<td></td>
</tr>
<tr>
<td>stereo recording 16</td>
<td></td>
</tr>
<tr>
<td>TDM Mixer plug-in</td>
<td></td>
</tr>
<tr>
<td>TDM Setup Indicator</td>
<td></td>
</tr>
<tr>
<td>toggle</td>
<td></td>
</tr>
</tbody>
</table>

| U                      | Universal Track Mode 10 |
| word length. See bit depth |                      |

| W                      | 24 Bit Recording option 11 |
| See bit depth          |                      |

Index